Panzer Elite Panzer Pack 2 1.2 beta

View previous topic View next topic Go down

Panzer Elite Panzer Pack 2 1.2 beta

Post  Murkz on Mon Nov 10, 2014 3:12 pm

The Panzer Elite Panzer Pack 2 1.2 beta, has been released over at PEDG.

http://pedg.yuku.com/topic/2315/PP2x-Download-Section

Requirements:
Runs on XP, Vista and Win 7 systems.
You must have PE updated/patched to version 1.2 before installing PP2-x.
DirectX version 9.0c must be installed for the game to run with PP2-x mod.









avatar
Murkz
Admin

Posts : 667
Join date : 2009-11-11
Age : 57

View user profile http://panzersim.forumotion.com

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum